O Futuro é a Liberdade

Discussões sobre Software Livre e Sociedade

Fazendo o modem 3G MD300 da Claro funcionar.

Posted by Paulo em 09/07/2009

Mais um artigo garimpado da internet sobre modems 3G. Não deixem de conferir!

O original é de autoria de Rafael Luis Beraldo está em: http://www.vivaolinux.com.br/dica/Fazendo-o-modem-3G-MD300-da-Claro-funcionar-no-Ubuntu/

Sony Ericson MD300

Sony Ericson MD300

Esta é uma dica que se baseia, mas se difere de outras dicas que achei por aí. Recentemente instalei Ubuntu Linux para uma amiga e tive dificuldades em fazer o modem 3G MD300 da Claro funcionar.

Consegui fazer funcionar com o gnome-ppp e o wvdial, mas eu queria deixar a coisa mais simples: que o networkmanager mandasse na criança. A solução foi configurar o networkmanager. Abaixo mostro como fiz. Essa dica funciona no Ubuntu 9.04.

Primeiramente vamos criar esse arquivo:

$ sudo vim /etc/udev/rules.d/50-md300modem.rules

E inserir, dentro dele, o seguinte texto:

ACTION!=”add”, GOTO=”3G_End”
BUS==”usb”, SYSFS{idProduct}==”d0cf”, SYSFS{idVendor}==”0fce”, PROGRAM=”/bin/sh -c ‘echo 3 > /sys/%p/device/bConfigurationValue'”
LABEL=”3G_End”

Agora reinicie o udev:

$ sudo /etc/init.d/udev restart

Pronto! Metade já foi. O que fizemos até agora foi criar uma regra para o udev. O udev monta o modem MD300 como um pendrive qualquer. Essa regra manda ele montar o MD300 como o modem 3G que é. Feito isso, conecte seu modem e espere ser reconhecido.

Uma tela de configuração vai aparecer. É simples: selecione Claro, e dê avançar até o fim. Agora clique no ícone do nm-applet, que fica na bandeja do GNOME, com o botão direito e em “Editar conexões”.

Escolha a conexão da Claro, na aba “Banda larga móvel”. Aqui, mude a senha para “Claro”, com o C maiúsculo. Logo em seguida altere o APN para “bandalarga.claro.com.br”. Finalmente, vá até a última aba, selecione “Automático (PPP)” em Método e saia da edição. Agora tente conectar pelo network manager como se conectaria normalmente a uma conexão de rede sem fio. Aqui funcionou perfeitamente!

Fazendo o Modem 3G MD300 da Claro Funcionar no Ubuntu foi originalmente postado no site Cabaladadá.

3g Está com problemas em configurar seu modem no Linux?
Tem problemas de conexão e sinal baixo?

Se você mora na região de Curitiba, eu posso ajudar.
Deixe um comentário neste post que entrarei em contato.


Bookmark and Share

Anúncios

6 Respostas to “Fazendo o modem 3G MD300 da Claro funcionar.”

  1. Luis said

    Instalei o Ubuntu Netbook Remix num eeepc 1005 ah e nao reconhece de jeito nenhum, já criei o arquivo .rules mas nao reconhece o que faço?
    abraços e valew

  2. Andreia said

    Bom dia,
    Instalei o Ubuntu 9.10 e agora não estou conseguindo fazer com que o MD300 funcione. Estava funcionando normalmente no 9.04 será que vou ter que voltar para o 9.04?

    • stellarium said

      Bom dia.
      Meu modem também não funcionou de primeira na atualização para o 9.10. Comigo funcionou assim:
      1 – Removi as conexões de banda larga 3G do Network Manager, despluguei o modem, pluguei de novo, e mandei ele configurar a conexão 3G de novo. Funcionou a conexão, mas não a navegação.
      2 – Abri o conteúdo do arquivo /etc/ppp/resolv.conf. Nele haviam 2 endereços de servidores DNS. Editei como sudo o arquivo /etc/resolv.conf, que estava vazio, e incluí os endereços dos servidores nele. Salvei, reinicei a conexão e os aplicativos (navegador, Empathy, etc.) e tudo voltou ao normal.

      Maiores detalhes no post “Ubuntu 9.10 Karmic Koala Netbook Remix – Primeiras Impressões“, que publiquei ontem.

      Abraço.

    • Ânderson said

      Cara Andreia,
      Eu estava com um problema similar, de jeito nenhum meu modem MD300 funcionava no Ubuntu 9.10, até que descobri em um forum, que infelizmente nao me recordo agora, um arquivo “rules” diferente para o Ubuntu 9.10 karmic koala, no conteudo do /etc/udev/rules.d/50-md300modem.rules insira as seguintes linhas:
      ACTION!=”add”, GOTO=”3G_End”
      SUBSYSTEMS==”usb”, ATTRS{idProduct}==”d0cf”, ATTRS{idVendor}==”0fce”, RUN+=”/bin/sh -c ‘echo 2 > /sys/%p/bConfigurationValue'”
      LABEL=”3G_End”

      Comente as linhas ja presentes no arquivo, para que elas sejam ignoradas (IMPORTANTE-> quando colar essas linhas no 50-md300modem.rules preste atenção as aspas simples e duplas)

      reinicie o udev (no meu caso precisei reiniciar o equipamento)
      Depois disso funcionou que foi uma beleza!
      Saudações.

  3. fanny said

    bem, estou com SERIOS problemas com a minha 3g da claro, nao sou de curitiba, mas quem sabe possa me ajudar, né?
    me manda um email para entrarmos em contato!

    obrigada 😀

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

 
%d blogueiros gostam disto: